Original release date: February 27, 2002
Last revised: --
A complete revision history can be found at the end of this file.
Multiple vulnerabilities exist in the PHP scripting language. These vulnerabilities could allow a remote attacker to execute arbitrary code with the privileges of the PHP process.
PHP is a scripting language widely used in web development. PHP can be installed on a variety of web servers, including Apache, IIS, Caudium, Netscape and iPlanet, OmniHTTPd and others. Vulnerabilities in the php_mime_split function may allow an
intruder to execute arbitrary code with the privileges of the web server. For additional details, see
Web servers that do not have PHP installed are not affected by this vulnerability.
The CERT/CC is tracking this set of vulnerabilities as VU#297363. At this time, these vulnerabilities have not been assigned a CVE identifier.
Intruders can execute arbitrary code with the privileges of the web server, or interrupt normal operations of the web server.
Apply a Patch
Upgrade to PHP version 4.1.2, available from
If upgrading is not possible, apply patches as described at http://www.php.net/downloads.php:
If you are using version 4.20-dev, you are not affected by this vulnerability. Quoting from http://security.e-matters.de/advisories/012002.htm:
"[U]sers running PHP 4.2.0-dev from cvs are not vulnerable to any of the described bugs because the fileupload code was completly rewritten for the 4.2.0 branch."
If upgrading is not possible or a patch cannot be applied, you can avoid these vulnerabilities by disabling fileupload support. Edit the PHP configuration file php.ini as follows:
file_uploads = off
Note that this setting only applies to version 4.0.3 and above. However, this will prevent you from using fileuploads, which may not be acceptable in your environment.
This appendix contains information provided by vendors for this advisory. When vendors report new information to the CERT/CC, we update this section and note the changes in our revision history. If a particular vendor is not listed below, we have not
received their comments.
Information about this vulnerability is available from http://www.php.net
FreeBSD does not include any version of PHP by default, and so is not vulnerable. However, the FreeBSD Ports Collection does contain both PHP3 and PHP4 packages. Updates to the PHP packages are in progress and corrected packages will be available in
the near future.
MandrakeSoft distributes PHP in all distributions and we are currently working on patching our versions of PHP for Linux-Mandrake 7.1 and 7.2; Mandrake Linux 8.0, 8.0/ppc, 8.1, and 8.1/ia64; Single Network Firewall 7.2; Corporate Server 1.0.1.
We anticipate having the updates out by the end of the week.
We do not use PHP in any products.
NCSA does not include PHP as an add-in or bundled component in any products distributed.
Red Hat was notified of this issue on 27th February 2002. All supported versions of Red Hat Linux ship with PHP packages that are affected by these vulnerabilities. We will shortly be releasing errata packages which contain patched versions that are
not vulnerable. The errata packages and our advisory will be available on our web site at the URL below. At the same time users of the Red Hat Network will be able to update their systems to patched versions using the up2date tool.
The CERT Coordination Center thanks Stefan Esser, upon whose advisory this document is largely based.
Author: Shawn V. Hernan
Copyright 2002 Carnegie Mellon University.
February 27, 2002: Initial release